Include a Other Software section in Help file
[geeqie.git] / doc / Makefile.am
index 3d9963a..a09a809 100644 (file)
@@ -2,14 +2,14 @@
 
 helpdir = @htmldir@
 
-EXTRA_DIST = docbook2html.sh docbook
+EXTRA_DIST = docbook2html.sh docbook icons
 
 html/GuideIndex.html: docbook/GuideIndex.xml
-       rm -rf html; mkdir html; cp $(srcdir)/icons/* html/
+       rm -rf html; mkdir html; cp $(srcdir)/icons/* html/; ./create-doxygen-lua-api.sh
        if [ -x "$(GNOME_DOC_TOOL)" ]; then \
-               "$(GNOME_DOC_TOOL)" html -o html $(srcdir)/docbook/GuideIndex.xml ; \
+               "$(GNOME_DOC_TOOL)" html -i -o html/ $(srcdir)/docbook/GuideIndex.xml ; \
        else \
-               echo "gnome-doc-tool not found, html is not built" ; \
+               echo "yelp-tools not found, html is not built" ; \
        fi
 
 html: html/GuideIndex.html
@@ -18,12 +18,13 @@ install-data-hook: html
        if [ -x "$(GNOME_DOC_TOOL)" ]; then \
                $(MKDIR_P) "$(DESTDIR)$(helpdir)" || exit 1; \
                cd $(srcdir)/html; for f in * ; do $(INSTALL_DATA) "$$f" "$(DESTDIR)$(helpdir)/$$f" ; done; \
-               ln -s GuideIndex.html "$(DESTDIR)$(helpdir)/index.html" ; \
+               ln -s -f GuideIndex.html "$(DESTDIR)$(helpdir)/index.html" ; \
+               $(MKDIR_P) "$(DESTDIR)$(helpdir)/lua-api" || exit 1; \
+               cd ./lua-api/html; for f in * ; do $(INSTALL_DATA) "$$f" "$(DESTDIR)$(helpdir)/lua-api/$$f" ; done; \
        fi
-       
+
 uninstall-hook:
-       rm "$(DESTDIR)$(helpdir)/"*
+       rm -r "$(DESTDIR)$(helpdir)/"*
 
 clean-local:
        rm -rf html
-