Fix #1004, 1005: Various meson problems
[geeqie.git] / scripts / generate-ClayRGB1998-icc-h.sh
old mode 100644 (file)
new mode 100755 (executable)
similarity index 55%
rename from doc/html/lua-api/meson.build
rename to scripts/generate-ClayRGB1998-icc-h.sh
index 2fa4547..8a55c22
@@ -1,11 +1,17 @@
+#!/bin/sh
+# This file is a part of Geeqie project (https://www.geeqie.org/).
 # Copyright (C) 2008 - 2022 The Geeqie Team
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
+# the Free Software: foundation; either version 2 of the License, or
 # (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#
+# GNU General Public License for more details.
+
+# To generate the required code, xxd has to run in the same folder as the source
+cd "$(dirname "$1")" || return 1
+xxd -i "$(basename "$1")"