Refactor: move view_file implementations to their own subdirectory.
[geeqie.git] / src / Makefile.am
index 05c55cf..15bdf1b 100644 (file)
@@ -7,6 +7,9 @@ AM_CFLAGS =                             \
        $(EXIV2_CFLAGS)                 \
        $(LIBCHAMPLAIN_CFLAGS)          \
        $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)   \
        -I$(top_srcdir)                 \
        -I$(top_builddir)
 
@@ -17,6 +20,9 @@ AM_CXXFLAGS =                         \
        $(EXIV2_CFLAGS)                 \
        $(LIBCHAMPLAIN_CFLAGS)          \
        $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)   \
        -I$(top_srcdir)                 \
        -I$(top_builddir)
 
@@ -74,10 +80,15 @@ CLEANFILES = $(noinst_DATA)
 extra_SLIK = \
        $(extra_ICONS)
 
+include $(srcdir)/pan-view/Makefile.am
+include $(srcdir)/view_file/Makefile.am
+
 bin_PROGRAMS = geeqie
 
 geeqie_SOURCES = \
        $(module_SLIK)  \
+       $(module_pan_view)      \
+       $(module_view_file)     \
        ClayRGB1998.icc \
        ClayRGB1998_icc.h \
        advanced_exif.c \
@@ -164,10 +175,14 @@ geeqie_SOURCES = \
        image_load_gdk.h\
        image_load_jpeg.c\
        image_load_jpeg.h\
+       image_load_tiff.c\
+       image_load_tiff.h\
        image-overlay.c \
        image-overlay.h \
        img-view.c      \
        img-view.h      \
+       jpeg_parser.c   \
+       jpeg_parser.h   \
        layout.c        \
        layout.h        \
        layout_config.c \
@@ -192,19 +207,13 @@ geeqie_SOURCES = \
        misc.h          \
        options.c       \
        options.h       \
-       pan-calendar.c  \
-       pan-folder.c    \
-       pan-grid.c      \
-       pan-item.c      \
-       pan-timeline.c  \
-       pan-types.h     \
-       pan-util.c      \
-       pan-view.c      \
        pan-view.h      \
        pixbuf-renderer.c       \
        pixbuf-renderer.h       \
        renderer-tiles.c        \
        renderer-tiles.h        \
+       renderer-clutter.c      \
+       renderer-clutter.h      \
        pixbuf_util.c   \
        pixbuf_util.h   \
        preferences.c   \
@@ -219,6 +228,8 @@ geeqie_SOURCES = \
        search.h        \
        secure_save.c   \
        secure_save.h   \
+       shortcuts.c     \
+       shortcuts.h     \
        similar.c       \
        similar.h       \
        slideshow.c     \
@@ -242,14 +253,12 @@ geeqie_SOURCES = \
        view_dir_tree.h \
        view_file.c     \
        view_file.h     \
-       view_file_list.c        \
-       view_file_list.h        \
-       view_file_icon.c        \
-       view_file_icon.h        \
        window.c        \
-       window.h
+       window.h        \
+       lua.c           \
+       glua.h
 
-geeqie_LDADD = $(GTK_LIBS) $(GLIB_LIBS) $(INTLLIBS) $(JPEG_LIBS) $(LCMS_LIBS) $(EXIV2_LIBS) $(LIBCHAMPLAIN_LIBS) $(LIBCHAMPLAIN_GTK_LIBS)
+geeqie_LDADD = $(GTK_LIBS) $(GLIB_LIBS) $(INTLLIBS) $(JPEG_LIBS) $(TIFF_LIBS) $(LCMS_LIBS) $(EXIV2_LIBS) $(LIBCHAMPLAIN_LIBS) $(LIBCHAMPLAIN_GTK_LIBS) $(LUA_LIBS) $(CLUTTER_LIBS) $(CLUTTER_GTK_LIBS)
 
 EXTRA_DIST = \
        $(extra_SLIK)
@@ -257,7 +266,7 @@ EXTRA_DIST = \
 gq-marshal.h: gq-marshal.list
        $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --header >$@
 
-gq-marshal.c: gq-marshal.list
+gq-marshal.c: gq-marshal.list gq-marshal.h
        (echo "#include \"gq-marshal.h\"" ; $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --body ) >$@