Refactor: move view_file implementations to their own subdirectory.
[geeqie.git] / src / Makefile.am
index 0dc9c39..15bdf1b 100644 (file)
@@ -1,9 +1,30 @@
 SUBDIRS = icons
 DIST_SUBDIRS = icons
 
-INCLUDES = -I$(srcdir) -I$(builddir)    \
-       -I$(top_srcdir) -I$(top_builddir)       \
-       -I$(includedir) $(GTK_CFLAGS)
+AM_CFLAGS =                            \
+       $(GLIB_CFLAGS) $(GTK_CFLAGS)    \
+       $(LCMS_CFLAGS)                  \
+       $(EXIV2_CFLAGS)                 \
+       $(LIBCHAMPLAIN_CFLAGS)          \
+       $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)   \
+       -I$(top_srcdir)                 \
+       -I$(top_builddir)
+
+
+AM_CXXFLAGS =                          \
+       $(GLIB_CFLAGS) $(GTK_CFLAGS)    \
+       $(LCMS_CFLAGS)                  \
+       $(EXIV2_CFLAGS)                 \
+       $(LIBCHAMPLAIN_CFLAGS)          \
+       $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)   \
+       -I$(top_srcdir)                 \
+       -I$(top_builddir)
 
 module_SLIK = \
        intl.h          \
@@ -44,7 +65,7 @@ ui_icons.h: $(extra_ICONS) Makefile.in
         echo '#endif /* UI_ICONS_H */') > $@ || echo "!!! Failed to generate $@ !!!"
 
 ClayRGB1998_icc.h: ClayRGB1998.icc
-       echo "/*" > $@ 
+       echo "/*" > $@
        echo " * This file was generated from ClayRGB1998.icc, DO NOT EDIT " >> $@
        echo " * http://www.argyllcms.com/ClayRGB1998.zip " >> $@
        echo " */ " >> $@
@@ -55,18 +76,33 @@ ui_spinner.o: ui_icons.h
 
 noinst_DATA = ui_icons.h
 CLEANFILES = $(noinst_DATA)
-                                                                                                                     
+
 extra_SLIK = \
        $(extra_ICONS)
 
+include $(srcdir)/pan-view/Makefile.am
+include $(srcdir)/view_file/Makefile.am
+
 bin_PROGRAMS = geeqie
 
 geeqie_SOURCES = \
        $(module_SLIK)  \
+       $(module_pan_view)      \
+       $(module_view_file)     \
        ClayRGB1998.icc \
        ClayRGB1998_icc.h \
-       bar_info.c      \
-       bar_info.h      \
+       advanced_exif.c \
+       advanced_exif.h \
+       bar.c           \
+       bar.h           \
+       bar_comment.c   \
+       bar_comment.h   \
+       bar_gps.c       \
+       bar_gps.h       \
+       bar_histogram.c \
+       bar_histogram.h \
+       bar_keywords.c  \
+       bar_keywords.h  \
        bar_exif.c      \
        bar_exif.h      \
        bar_sort.c      \
@@ -91,6 +127,10 @@ geeqie_SOURCES = \
        color-man.h     \
        compat.c        \
        compat.h        \
+       debug.c         \
+       debug.h         \
+       desktop_file.c  \
+       desktop_file.h  \
        dnd.c           \
        dnd.h           \
        dupe.c          \
@@ -102,8 +142,15 @@ geeqie_SOURCES = \
        exif-int.h      \
        exif-common.c   \
        exiv2.cc        \
-       filelist.c      \
-       filelist.h      \
+       filecache.c     \
+       filecache.h     \
+       filedata.c      \
+       filedata.h      \
+       filefilter.c    \
+       filefilter.h    \
+       gq-marshal.c    \
+       gq-marshal.h    \
+       gq-marshal.list \
        format_canon.c  \
        format_canon.h  \
        format_fuji.c   \
@@ -116,19 +163,26 @@ geeqie_SOURCES = \
        format_raw.h    \
        fullscreen.c    \
        fullscreen.h    \
-       globals.c       \
        histogram.c     \
        histogram.h     \
+       history_list.c  \
+       history_list.h  \
        image.c         \
        image.h         \
        image-load.c    \
        image-load.h    \
+       image_load_gdk.c\
+       image_load_gdk.h\
+       image_load_jpeg.c\
+       image_load_jpeg.h\
+       image_load_tiff.c\
+       image_load_tiff.h\
        image-overlay.c \
        image-overlay.h \
        img-view.c      \
        img-view.h      \
-       info.c          \
-       info.h          \
+       jpeg_parser.c   \
+       jpeg_parser.h   \
        layout.c        \
        layout.h        \
        layout_config.c \
@@ -137,23 +191,29 @@ geeqie_SOURCES = \
        layout_image.h  \
        layout_util.c   \
        layout_util.h   \
+       lirc.c          \
+       lirc.h          \
+       logwindow.c     \
+       logwindow.h     \
        main.c          \
        main.h          \
        md5-util.c      \
        md5-util.h      \
        menu.c          \
        menu.h          \
-       pan-calendar.c  \
-       pan-folder.c    \
-       pan-grid.c      \
-       pan-item.c      \
-       pan-timeline.c  \
-       pan-types.h     \
-       pan-util.c      \
-       pan-view.c      \
+       metadata.c      \
+       metadata.h      \
+       misc.c          \
+       misc.h          \
+       options.c       \
+       options.h       \
        pan-view.h      \
        pixbuf-renderer.c       \
        pixbuf-renderer.h       \
+       renderer-tiles.c        \
+       renderer-tiles.h        \
+       renderer-clutter.c      \
+       renderer-clutter.h      \
        pixbuf_util.c   \
        pixbuf_util.h   \
        preferences.c   \
@@ -168,6 +228,8 @@ geeqie_SOURCES = \
        search.h        \
        secure_save.c   \
        secure_save.h   \
+       shortcuts.c     \
+       shortcuts.h     \
        similar.c       \
        similar.h       \
        slideshow.c     \
@@ -177,6 +239,10 @@ geeqie_SOURCES = \
        thumb.h         \
        thumb_standard.c        \
        thumb_standard.h        \
+       trash.c         \
+       trash.h         \
+       uri_utils.c     \
+       uri_utils.h     \
        utilops.c       \
        utilops.h       \
        view_dir.c      \
@@ -185,13 +251,23 @@ geeqie_SOURCES = \
        view_dir_list.h \
        view_dir_tree.c \
        view_dir_tree.h \
-       view_file_list.c        \
-       view_file_list.h        \
-       view_file_icon.c        \
-       view_file_icon.h
+       view_file.c     \
+       view_file.h     \
+       window.c        \
+       window.h        \
+       lua.c           \
+       glua.h
 
-geeqie_LDADD = $(GTK_LIBS) $(INTLLIBS) $(LCMS_LIBS) $(EXIV2_LIBS)
+geeqie_LDADD = $(GTK_LIBS) $(GLIB_LIBS) $(INTLLIBS) $(JPEG_LIBS) $(TIFF_LIBS) $(LCMS_LIBS) $(EXIV2_LIBS) $(LIBCHAMPLAIN_LIBS) $(LIBCHAMPLAIN_GTK_LIBS) $(LUA_LIBS) $(CLUTTER_LIBS) $(CLUTTER_GTK_LIBS)
 
 EXTRA_DIST = \
        $(extra_SLIK)
 
+gq-marshal.h: gq-marshal.list
+       $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --header >$@
+
+gq-marshal.c: gq-marshal.list gq-marshal.h
+       (echo "#include \"gq-marshal.h\"" ; $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --body ) >$@
+
+
+