Bug fix: Non-portable functions
[geeqie.git] / src / Makefile.am
index 237e6f2..5fbc303 100644 (file)
@@ -7,6 +7,15 @@ AM_CFLAGS =                            \
        $(EXIV2_CFLAGS)                 \
        $(LIBCHAMPLAIN_CFLAGS)          \
        $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)           \
+       $(FFMPEGTHUMBNAILER_CFLAGS)     \
+       $(PDF_CFLAGS)   \
+       $(HEIF_CFLAGS)  \
+       $(WEBP_CFLAGS)  \
+       $(J2K_CFLAGS)   \
+       $(JPEGXL_CFLAGS)        \
        -I$(top_srcdir)                 \
        -I$(top_builddir)
 
@@ -17,6 +26,15 @@ AM_CXXFLAGS =                                \
        $(EXIV2_CFLAGS)                 \
        $(LIBCHAMPLAIN_CFLAGS)          \
        $(LIBCHAMPLAIN_GTK_CFLAGS)      \
+       $(LUA_CFLAGS)                   \
+       $(CLUTTER_CFLAGS)               \
+       $(CLUTTER_GTK_CFLAGS)           \
+       $(FFMPEGTHUMBNAILER_CFLAGS)     \
+       $(PDF_CFLAGS)   \
+       $(HEIF_CFLAGS)  \
+       $(WEBP_CFLAGS)  \
+       $(J2K_CFLAGS)   \
+       $(JPEGXL_CFLAGS)        \
        -I$(top_srcdir)                 \
        -I$(top_builddir)
 
@@ -52,11 +70,11 @@ ICON_PAIRS = \
        icon_tabcomp            $(srcdir)/ui_tabcomp.png
 
 ui_icons.h: $(extra_ICONS) Makefile.in
-       @(echo '/* Auto generated file, do not edit */'; echo; \
+       @sh -ec "echo '/* Auto generated file, do not edit */'; echo; \
         echo '#ifndef UI_ICONS_H'; \
         echo '#define UI_ICONS_H'; echo; \
         $(GDK_PIXBUF_CSOURCE) --raw --extern --build-list $(ICON_PAIRS); \
-        echo '#endif /* UI_ICONS_H */') > $@ || echo "!!! Failed to generate $@ !!!"
+        echo '#endif /* UI_ICONS_H */'" > $@ || { echo "!!! Failed to generate $@ !!!"; exit 1; }
 
 ClayRGB1998_icc.h: ClayRGB1998.icc
        echo "/*" > $@
@@ -74,10 +92,15 @@ CLEANFILES = $(noinst_DATA)
 extra_SLIK = \
        $(extra_ICONS)
 
+include $(srcdir)/pan-view/Makefile.am
+include $(srcdir)/view_file/Makefile.am
+
 bin_PROGRAMS = geeqie
 
 geeqie_SOURCES = \
        $(module_SLIK)  \
+       $(module_pan_view)      \
+       $(module_view_file)     \
        ClayRGB1998.icc \
        ClayRGB1998_icc.h \
        advanced_exif.c \
@@ -160,10 +183,40 @@ geeqie_SOURCES = \
        image.h         \
        image-load.c    \
        image-load.h    \
+       image_load_cr3.c\
+       image_load_cr3.h\
        image_load_gdk.c\
        image_load_gdk.h\
        image_load_jpeg.c\
        image_load_jpeg.h\
+       image_load_tiff.c\
+       image_load_tiff.h\
+       image_load_dds.c\
+       image_load_dds.h\
+       image_load_external.c\
+       image_load_external.h\
+       image_load_collection.c\
+       image_load_collection.h\
+       image_load_pdf.c\
+       image_load_pdf.h\
+       image_load_heif.c\
+       image_load_heif.h\
+       image_load_webp.c\
+       image_load_webp.h\
+       image_load_djvu.c\
+       image_load_djvu.h\
+       image_load_psd.c\
+       image_load_psd.h\
+       image_load_j2k.c\
+       image_load_j2k.h\
+       image_load_jpegxl.c\
+       image_load_jpegxl.h\
+       image_load_libraw.c\
+       image_load_libraw.h\
+       image_load_svgz.c\
+       image_load_svgz.h\
+       image_load_ffmpegthumbnailer.c\
+       image_load_ffmpegthumbnailer.h\
        image-overlay.c \
        image-overlay.h \
        img-view.c      \
@@ -178,6 +231,8 @@ geeqie_SOURCES = \
        layout_image.h  \
        layout_util.c   \
        layout_util.h   \
+       keymap_template.c\
+       keymap_template.h\
        lirc.c          \
        lirc.h          \
        logwindow.c     \
@@ -194,19 +249,15 @@ geeqie_SOURCES = \
        misc.h          \
        options.c       \
        options.h       \
-       pan-calendar.c  \
-       pan-folder.c    \
-       pan-grid.c      \
-       pan-item.c      \
-       pan-timeline.c  \
-       pan-types.h     \
-       pan-util.c      \
-       pan-view.c      \
+       osd.c   \
+       osd.h   \
        pan-view.h      \
        pixbuf-renderer.c       \
        pixbuf-renderer.h       \
        renderer-tiles.c        \
        renderer-tiles.h        \
+       renderer-clutter.c      \
+       renderer-clutter.h      \
        pixbuf_util.c   \
        pixbuf_util.h   \
        preferences.c   \
@@ -219,8 +270,12 @@ geeqie_SOURCES = \
        rcfile.h        \
        search.c        \
        search.h        \
+       search_and_run.c        \
+       search_and_run.h        \
        secure_save.c   \
        secure_save.h   \
+       shortcuts.c     \
+       shortcuts.h     \
        similar.c       \
        similar.h       \
        slideshow.c     \
@@ -230,6 +285,8 @@ geeqie_SOURCES = \
        thumb.h         \
        thumb_standard.c        \
        thumb_standard.h        \
+       toolbar.c       \
+       toolbar.h       \
        trash.c         \
        trash.h         \
        uri_utils.c     \
@@ -242,25 +299,25 @@ geeqie_SOURCES = \
        view_dir_list.h \
        view_dir_tree.c \
        view_dir_tree.h \
-       view_file.c     \
        view_file.h     \
-       view_file_list.c        \
-       view_file_list.h        \
-       view_file_icon.c        \
-       view_file_icon.h        \
+       whereami.c      \
+       whereami.h      \
        window.c        \
-       window.h
+       window.h        \
+       lua.c           \
+       glua.h          \
+       zonedetect.c    \
+       zonedetect.h
 
-geeqie_LDADD = $(GTK_LIBS) $(GLIB_LIBS) $(INTLLIBS) $(JPEG_LIBS) $(LCMS_LIBS) $(EXIV2_LIBS) $(LIBCHAMPLAIN_LIBS) $(LIBCHAMPLAIN_GTK_LIBS)
+geeqie_LDADD = $(GTK_LIBS) $(GLIB_LIBS) $(INTLLIBS) $(JPEG_LIBS) $(TIFF_LIBS) $(LCMS_LIBS) $(EXIV2_LIBS) $(LIBCHAMPLAIN_LIBS) $(LIBCHAMPLAIN_GTK_LIBS) $(LUA_LIBS) $(CLUTTER_LIBS) $(CLUTTER_GTK_LIBS) $(FFMPEGTHUMBNAILER_LIBS) $(PDF_LIBS) $(HEIF_LIBS) $(WEBP_LIBS) $(DJVU_LIBS) $(J2K_LIBS) $(RAW_LIBS) $(JPEGXL_LIBS) $(ARCHIVE_LIBS)
 
 EXTRA_DIST = \
        $(extra_SLIK)
 
+image-load.o: gq-marshal.h
+
 gq-marshal.h: gq-marshal.list
        $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --header >$@
 
-gq-marshal.c: gq-marshal.list
+gq-marshal.c: gq-marshal.list gq-marshal.h
        (echo "#include \"gq-marshal.h\"" ; $(GLIB_GENMARSHAL) --prefix=gq_marshal $(srcdir)/gq-marshal.list --body ) >$@
-
-
-