Start building a class to enable clustering of files.
[geeqie.git] / src / Makefile.am
index b78e258..f4f2f4c 100644 (file)
@@ -80,10 +80,15 @@ CLEANFILES = $(noinst_DATA)
 extra_SLIK = \
        $(extra_ICONS)
 
+include $(srcdir)/pan-view/Makefile.am
+include $(srcdir)/view_file/Makefile.am
+
 bin_PROGRAMS = geeqie
 
 geeqie_SOURCES = \
        $(module_SLIK)  \
+       $(module_pan_view)      \
+       $(module_view_file)     \
        ClayRGB1998.icc \
        ClayRGB1998_icc.h \
        advanced_exif.c \
@@ -139,6 +144,8 @@ geeqie_SOURCES = \
        exiv2.cc        \
        filecache.c     \
        filecache.h     \
+       filecluster.c   \
+       filecluster.h   \
        filedata.c      \
        filedata.h      \
        filefilter.c    \
@@ -202,20 +209,6 @@ geeqie_SOURCES = \
        misc.h          \
        options.c       \
        options.h       \
-       pan-calendar.c  \
-       pan-calendar.h  \
-       pan-folder.c    \
-       pan-folder.h    \
-       pan-grid.c      \
-       pan-grid.h      \
-       pan-item.c      \
-       pan-item.h      \
-       pan-timeline.c  \
-       pan-timeline.h  \
-       pan-types.h     \
-       pan-util.c      \
-       pan-util.h      \
-       pan-view.c      \
        pan-view.h      \
        pixbuf-renderer.c       \
        pixbuf-renderer.h       \
@@ -237,6 +230,8 @@ geeqie_SOURCES = \
        search.h        \
        secure_save.c   \
        secure_save.h   \
+       shortcuts.c     \
+       shortcuts.h     \
        similar.c       \
        similar.h       \
        slideshow.c     \
@@ -258,12 +253,7 @@ geeqie_SOURCES = \
        view_dir_list.h \
        view_dir_tree.c \
        view_dir_tree.h \
-       view_file.c     \
        view_file.h     \
-       view_file_list.c        \
-       view_file_list.h        \
-       view_file_icon.c        \
-       view_file_icon.h        \
        window.c        \
        window.h        \
        lua.c           \