Move third-party sources to separate sub-directory
[geeqie.git] / src / meson.build
index 78e39c4..288c301 100644 (file)
@@ -13,7 +13,6 @@
 
 main_sources = files('advanced-exif.cc',
 'advanced-exif.h',
-'backward.h',
 'bar.cc',
 'bar-comment.cc',
 'bar-comment.h',
@@ -124,6 +123,8 @@ main_sources = files('advanced-exif.cc',
 'image-load-svgz.h',
 'image-load-tiff.cc',
 'image-load-tiff.h',
+'image-load-webp.cc',
+'image-load-webp.h',
 'image-load-zxscr.cc',
 'image-load-zxscr.h',
 'image-overlay.cc',
@@ -148,6 +149,7 @@ main_sources = files('advanced-exif.cc',
 'lua.cc',
 'main.cc',
 'main.h',
+'main-defines.h',
 'md5-util.cc',
 'md5-util.h',
 'menu.cc',
@@ -225,18 +227,15 @@ main_sources = files('advanced-exif.cc',
 'view-dir-tree.cc',
 'view-dir-tree.h',
 'view-file.h',
-'whereami.cc',
-'whereami.h',
 'window.cc',
-'window.h',
-'zonedetect.cc',
-'zonedetect.h')
+'window.h')
 
 project_sources += main_sources
 
 subdir('authors')
 subdir('icons')
 subdir('pan-view')
+subdir('third-party')
 subdir('ui')
 subdir('view-file')
 
@@ -253,17 +252,7 @@ gq_marshal_pragma = custom_target('gq-marshal-pragma',
 
 project_sources += gq_marshal_pragma
 
-icon_pairs = [
-'icon_tabcomp', files('ui_tabcomp.png'),
-]
-
-ui_icons_h = custom_target('ui_icons', output : 'ui_icons.h',
-                command : [gdk_pixbuf_csource, '--raw', '--extern', '--build-list', icon_pairs],
-                capture : true)
-
-project_sources += ui_icons_h
-
-if conf_data.has('HAVE_LCMS')
+if conf_data.get('HAVE_LCMS', 0) == 1
     xxd_sh = find_program('generate-ClayRGB1998-icc-h.sh', dirs : join_paths(meson.project_source_root(), 'scripts'))
 
     ClayRGB1998_icc_h = custom_target('ClayRGB1998',
@@ -296,6 +285,7 @@ libjxl_dep,
 libopenjp2_dep,
 libraw_dep,
 libunwind_dep,
+libwebp_dep,
 lua_dep,
 poppler_glib_dep,
 thread_dep,