Move third-party sources to separate sub-directory
[geeqie.git] / src / meson.build
index f23dbf7..288c301 100644 (file)
@@ -13,7 +13,6 @@
 
 main_sources = files('advanced-exif.cc',
 'advanced-exif.h',
-'backward.h',
 'bar.cc',
 'bar-comment.cc',
 'bar-comment.h',
@@ -150,6 +149,7 @@ main_sources = files('advanced-exif.cc',
 'lua.cc',
 'main.cc',
 'main.h',
+'main-defines.h',
 'md5-util.cc',
 'md5-util.h',
 'menu.cc',
@@ -227,18 +227,15 @@ main_sources = files('advanced-exif.cc',
 'view-dir-tree.cc',
 'view-dir-tree.h',
 'view-file.h',
-'whereami.cc',
-'whereami.h',
 'window.cc',
-'window.h',
-'zonedetect.cc',
-'zonedetect.h')
+'window.h')
 
 project_sources += main_sources
 
 subdir('authors')
 subdir('icons')
 subdir('pan-view')
+subdir('third-party')
 subdir('ui')
 subdir('view-file')
 
@@ -255,7 +252,7 @@ gq_marshal_pragma = custom_target('gq-marshal-pragma',
 
 project_sources += gq_marshal_pragma
 
-if conf_data.has('HAVE_LCMS')
+if conf_data.get('HAVE_LCMS', 0) == 1
     xxd_sh = find_program('generate-ClayRGB1998-icc-h.sh', dirs : join_paths(meson.project_source_root(), 'scripts'))
 
     ClayRGB1998_icc_h = custom_target('ClayRGB1998',