Include executable test in GitHub action
[geeqie.git] / src / meson.build
index 16c9a8a..2930469 100644 (file)
@@ -13,6 +13,7 @@
 
 main_sources = files('advanced-exif.cc',
 'advanced-exif.h',
+'backward.h',
 'bar.cc',
 'bar-comment.cc',
 'bar-comment.h',
@@ -123,8 +124,6 @@ main_sources = files('advanced-exif.cc',
 'image-load-svgz.h',
 'image-load-tiff.cc',
 'image-load-tiff.h',
-'image-load-webp.cc',
-'image-load-webp.h',
 'image-load-zxscr.cc',
 'image-load-zxscr.h',
 'image-overlay.cc',
@@ -237,6 +236,7 @@ main_sources = files('advanced-exif.cc',
 
 project_sources += main_sources
 
+subdir('authors')
 subdir('icons')
 subdir('pan-view')
 subdir('view-file')
@@ -256,16 +256,18 @@ ui_icons_h = custom_target('ui_icons', output : 'ui_icons.h',
 
 project_sources += ui_icons_h
 
-xxd = find_program('generate-ClayRGB1998-icc-h.sh', dirs : join_paths(meson.source_root(), 'scripts'))
+if conf_data.has('HAVE_LCMS')
+    xxd_sh = find_program('generate-ClayRGB1998-icc-h.sh', dirs : join_paths(meson.project_source_root(), 'scripts'))
 
-ClayRGB1998_icc_h = custom_target('ClayRGB1998',
-                    input: 'ClayRGB1998.icc',
-                    output : 'ClayRGB1998_icc.h',
-                    command : [xxd, '@INPUT@', '@OUTPUT@'])
+    ClayRGB1998_icc_h = custom_target('ClayRGB1998',
+                        input: 'ClayRGB1998.icc',
+                        output : 'ClayRGB1998_icc.h',
+                        command : [xxd_sh, '@INPUT@', '@OUTPUT@'])
 
-project_sources += ClayRGB1998_icc_h
+    project_sources += ClayRGB1998_icc_h
+endif
 
-executable('geeqie', project_sources,
+geeqie_exe = executable('geeqie', project_sources,
 dependencies : [
 gtk_dep,
 champlain_dep,
@@ -278,13 +280,14 @@ glib_dep,
 gspell_dep,
 lcms_dep,
 libarchive_dep,
+libdw_dep,
 libffmpegthumbnailer_dep,
 libheif_dep,
 libjpeg_dep,
 libjxl_dep,
 libopenjp2_dep,
 libraw_dep,
-libwebp_dep,
+libunwind_dep,
 lua_dep,
 poppler_glib_dep,
 thread_dep,