Updates references from using underscore filenames to hyphen filenames for files...
[geeqie.git] / src / meson.build
index 2500921..fc9fb38 100644 (file)
 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 # GNU General Public License for more details.
 
-main_sources = files('advanced_exif.c',
-'advanced_exif.h',
+main_sources = files('advanced-exif.c',
+'advanced-exif.h',
 'bar.c',
-'bar_comment.c',
-'bar_comment.h',
-'bar_exif.c',
-'bar_exif.h',
-'bar_gps.c',
-'bar_gps.h',
+'bar-comment.c',
+'bar-comment.h',
+'bar-exif.c',
+'bar-exif.h',
+'bar-gps.c',
+'bar-gps.h',
 'bar.h',
-'bar_histogram.c',
-'bar_histogram.h',
-'bar_keywords.c',
-'bar_keywords.h',
-'bar_rating.c',
-'bar_rating.h',
-'bar_sort.c',
-'bar_sort.h',
+'bar-histogram.c',
+'bar-histogram.h',
+'bar-keywords.c',
+'bar-keywords.h',
+'bar-rating.c',
+'bar-rating.h',
+'bar-sort.c',
+'bar-sort.h',
 'cache.c',
 'cache.h',
 'cache-loader.c',
 'cache-loader.h',
-'cache_maint.c',
-'cache_maint.h',
+'cache-maint.c',
+'cache-maint.h',
 'cellrenderericon.c',
 'cellrenderericon.h',
 'collect.c',
@@ -51,8 +51,8 @@ main_sources = files('advanced_exif.c',
 'compat.h',
 'debug.c',
 'debug.h',
-'desktop_file.c',
-'desktop_file.h',
+'desktop-file.c',
+'desktop-file.h',
 'dnd.c',
 'dnd.h',
 'dupe.c',
@@ -70,80 +70,80 @@ main_sources = files('advanced_exif.c',
 'filedata.h',
 'filefilter.c',
 'filefilter.h',
-'format_canon.c',
-'format_canon.h',
-'format_fuji.c',
-'format_fuji.h',
-'format_nikon.c',
-'format_nikon.h',
-'format_olympus.c',
-'format_olympus.h',
-'format_raw.c',
-'format_raw.h',
+'format-canon.c',
+'format-canon.h',
+'format-fuji.c',
+'format-fuji.h',
+'format-nikon.c',
+'format-nikon.h',
+'format-olympus.c',
+'format-olympus.h',
+'format-raw.c',
+'format-raw.h',
 'fullscreen.c',
 'fullscreen.h',
 'glua.h',
 'histogram.c',
 'histogram.h',
-'history_list.c',
-'history_list.h',
+'history-list.c',
+'history-list.h',
 'image.c',
 'image.h',
 'image-load.c',
-'image_load_collection.c',
-'image_load_collection.h',
-'image_load_cr3.c',
-'image_load_cr3.h',
-'image_load_dds.c',
-'image_load_dds.h',
-'image_load_djvu.c',
-'image_load_djvu.h',
-'image_load_external.c',
-'image_load_external.h',
-'image_load_ffmpegthumbnailer.c',
-'image_load_ffmpegthumbnailer.h',
-'image_load_gdk.c',
-'image_load_gdk.h',
+'image-load-collection.c',
+'image-load-collection.h',
+'image-load-cr3.c',
+'image-load-cr3.h',
+'image-load-dds.c',
+'image-load-dds.h',
+'image-load-djvu.c',
+'image-load-djvu.h',
+'image-load-external.c',
+'image-load-external.h',
+'image-load-ffmpegthumbnailer.c',
+'image-load-ffmpegthumbnailer.h',
+'image-load-gdk.c',
+'image-load-gdk.h',
 'image-load.h',
-'image_load_heif.c',
-'image_load_heif.h',
-'image_load_j2k.c',
-'image_load_j2k.h',
-'image_load_jpeg.c',
-'image_load_jpeg.h',
-'image_load_jpegxl.c',
-'image_load_jpegxl.h',
-'image_load_libraw.c',
-'image_load_libraw.h',
-'image_load_pdf.c',
-'image_load_pdf.h',
-'image_load_psd.c',
-'image_load_psd.h',
-'image_load_svgz.c',
-'image_load_svgz.h',
-'image_load_tiff.c',
-'image_load_tiff.h',
-'image_load_webp.c',
-'image_load_webp.h',
-'image_load_zxscr.c',
-'image_load_zxscr.h',
+'image-load-heif.c',
+'image-load-heif.h',
+'image-load-j2k.c',
+'image-load-j2k.h',
+'image-load-jpeg.c',
+'image-load-jpeg.h',
+'image-load-jpegxl.c',
+'image-load-jpegxl.h',
+'image-load-libraw.c',
+'image-load-libraw.h',
+'image-load-pdf.c',
+'image-load-pdf.h',
+'image-load-psd.c',
+'image-load-psd.h',
+'image-load-svgz.c',
+'image-load-svgz.h',
+'image-load-tiff.c',
+'image-load-tiff.h',
+'image-load-webp.c',
+'image-load-webp.h',
+'image-load-zxscr.c',
+'image-load-zxscr.h',
 'image-overlay.c',
 'image-overlay.h',
 'img-view.c',
 'img-view.h',
 'intl.h',
-'jpeg_parser.c',
-'jpeg_parser.h',
-'keymap_template.c',
-'keymap_template.h',
+'jpeg-parser.c',
+'jpeg-parser.h',
+'keymap-template.c',
+'keymap-template.h',
 'layout.c',
-'layout_config.c',
-'layout_config.h',
+'layout-config.c',
+'layout-config.h',
 'layout.h',
-'layout_image.c',
-'layout_image.h',
-'layout_util.c',
-'layout_util.h',
+'layout-image.c',
+'layout-image.h',
+'layout-util.c',
+'layout-util.h',
 'logwindow.c',
 'logwindow.h',
 'lua.c',
@@ -164,8 +164,8 @@ main_sources = files('advanced_exif.c',
 'pan-view.h',
 'pixbuf-renderer.c',
 'pixbuf-renderer.h',
-'pixbuf_util.c',
-'pixbuf_util.h',
+'pixbuf-util.c',
+'pixbuf-util.h',
 'preferences.c',
 'preferences.h',
 'print.c',
@@ -176,12 +176,12 @@ main_sources = files('advanced_exif.c',
 'remote.h',
 'renderer-tiles.c',
 'renderer-tiles.h',
-'search_and_run.c',
-'search_and_run.h',
+'search-and-run.c',
+'search-and-run.h',
 'search.c',
 'search.h',
-'secure_save.c',
-'secure_save.h',
+'secure-save.c',
+'secure-save.h',
 'shortcuts.c',
 'shortcuts.h',
 'similar.c',
@@ -190,44 +190,44 @@ main_sources = files('advanced_exif.c',
 'slideshow.h',
 'thumb.c',
 'thumb.h',
-'thumb_standard.c',
-'thumb_standard.h',
+'thumb-standard.c',
+'thumb-standard.h',
 'toolbar.c',
 'toolbar.h',
 'trash.c',
 'trash.h',
 'typedefs.h',
-'ui_bookmark.c',
-'ui_bookmark.h',
-'ui_fileops.c',
-'ui_fileops.h',
-'ui_help.c',
-'ui_help.h',
-'ui_menu.c',
-'ui_menu.h',
-'ui_misc.c',
-'ui_misc.h',
-'ui_pathsel.c',
-'ui_pathsel.h',
-'ui_spinner.c',
-'ui_spinner.h',
-'ui_tabcomp.c',
-'ui_tabcomp.h',
-'ui_tree_edit.c',
-'ui_tree_edit.h',
-'ui_utildlg.c',
-'ui_utildlg.h',
-'uri_utils.c',
-'uri_utils.h',
+'ui-bookmark.c',
+'ui-bookmark.h',
+'ui-fileops.c',
+'ui-fileops.h',
+'ui-help.c',
+'ui-help.h',
+'ui-menu.c',
+'ui-menu.h',
+'ui-misc.c',
+'ui-misc.h',
+'ui-pathsel.c',
+'ui-pathsel.h',
+'ui-spinner.c',
+'ui-spinner.h',
+'ui-tabcomp.c',
+'ui-tabcomp.h',
+'ui-tree-edit.c',
+'ui-tree-edit.h',
+'ui-utildlg.c',
+'ui-utildlg.h',
+'uri-utils.c',
+'uri-utils.h',
 'utilops.c',
 'utilops.h',
-'view_dir.c',
-'view_dir.h',
-'view_dir_list.c',
-'view_dir_list.h',
-'view_dir_tree.c',
-'view_dir_tree.h',
-'view_file.h',
+'view-dir.c',
+'view-dir.h',
+'view-dir-list.c',
+'view-dir-list.h',
+'view-dir-tree.c',
+'view-dir-tree.h',
+'view-file.h',
 'whereami.c',
 'whereami.h',
 'window.c',
@@ -239,7 +239,7 @@ project_sources += main_sources
 
 subdir('icons')
 subdir('pan-view')
-subdir('view_file')
+subdir('view-file')
 
 gqmarshal = gnome.genmarshal('gq-marshal', prefix : 'gq_marshal', sources : 'gq-marshal.list')
 project_sources += gqmarshal[0]